TomnekoSoft.com

Backend blog for TomnekoSoft.com


Firebird Square

Firebird3 Beta1がリリースされました

Firebird3Beta1がリリース



長らく(本当に長らく)待たされた、Firebird3の開発ですが、ようやくBeta1がリリースされました。

正式版のリリースは2015年の早々にということになっていますが、今までのリリース状況から見ると前半に出ればいいほうかな?

プロジェクトはすでにBeta2にとりかかっていますが、まずはBeta1でのテストに参加して欲しいと呼びかけています。

ローンチキャンペーン開始



また、Firebird3のリリースに向けて、ローンチキャンペーンを開始。以下のサイトを立ち上げましたので、ぜひ御覧ください。

http://www.firebird3.com/

ダウンロードページ

http://www.firebird3.com/en/download-firebird-3/

※Windows32bit/64bitとLinux32bit/64bit向けが用意されています。

Beta1 アンオフィシャルインストーラーにはGLIBC_2.14が必要


(2014年10月29日追記)

Firebird3のLinux版では、kernel - 2.6.39 と glibc - 2.12 が必要と"Minimum Linux requirements for Firebird 3" に記載があります。

試しにCentOS6.5へインストールしてみたところ、GLIBC_2.14が必要というエラーメッセージが表示されて起動することが出来ません。

事情を確認したところ、オフィシャルインストーラーでは修正されるようですが、アンオフィシャルインストーラーではGLIBC_2.14が必要とAlexey Kovyazinから回答がありました。

残念ながら、CentOSはバージョン7でもglibcのバージョンは2.12なので、fedoraとかubuntuに入れてみたほうがよさそうです。

(2014年11月7日追記)

10月30日にアンオフィシャルインストーラーを更新したよという連絡がありましたが、ようやく試せました。現在公開されているアンオフィシャルインストーラーは、CentOS6.5でもインストール可能で、Firebird3Beta1が正常に起動することを確認しました。


2014年10月23日 09:31 | Firebird Square | tomneko


コメント

コメントはまだありません

このアイテムは閲覧専用です。コメントの投稿、投票はできません。